summaryrefslogtreecommitdiffstats
path: root/source/l/python-lxml/python-lxml.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/python-lxml/python-lxml.SlackBuild')
-rwxr-xr-xsource/l/python-lxml/python-lxml.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/source/l/python-lxml/python-lxml.SlackBuild b/source/l/python-lxml/python-lxml.SlackBuild
index 609749652..3e51e4aab 100755
--- a/source/l/python-lxml/python-lxml.SlackBuild
+++ b/source/l/python-lxml/python-lxml.SlackBuild
@@ -1,6 +1,7 @@
#!/bin/bash
# Copyright 2022 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2024 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -75,7 +76,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-python3 setup.py install --root=$PKG || exit 1
+unshare -n python3 -m build --wheel --no-isolation || exit 1
+
+python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null