summaryrefslogtreecommitdiffstats
path: root/testing/source/linux-6.6.x/kernel-headers.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2023-11-21 21:15:30 +0000
committer Eric Hameleers <alien@slackware.com>2023-11-21 23:50:07 +0100
commit2dbdcbb842a23de51324253e20ce7b85670b80d7 (patch)
tree372b82c82f7b6d35752c729af2528cedf7c127ec /testing/source/linux-6.6.x/kernel-headers.SlackBuild
parent87febd8065f4770dda85eec79d9bfb6ec4e06fe7 (diff)
downloadcurrent-2dbdcbb842a23de51324253e20ce7b85670b80d7.tar.gz
current-2dbdcbb842a23de51324253e20ce7b85670b80d7.tar.xz
Tue Nov 21 21:15:30 UTC 202320231121211530
We have fresh 6.6 kernels in /testing! You may notice that on the 32-bit side we have done away with the -smp labeled kernel packages, but it's actually the other kernels that were retired -- the non-SMP, non-PAE ones. If you were previously using kernel-generic-smp or kernel-huge-smp, you'll need to make some adjustments to your bootloader setup to load kernel-generic or kernel-huge instead. About the only non-obsolete CPUs that may have an issue with this are the first generation Pentium M chips, which supported PAE but unfortunately did not advertise this in the CPU flags. But these will support PAE if the kernel option "forcepae" is appended at boot time. Enjoy! :-) a/gettext-0.22.4-x86_64-1.txz: Upgraded. a/kbd-2.6.3-x86_64-3.txz: Rebuilt. Installed extra console fonts. a/kernel-firmware-20231120_9552083-noarch-1.txz: Upgraded. a/kernel-generic-6.1.63-x86_64-1.txz: Upgraded. a/kernel-huge-6.1.63-x86_64-1.txz: Upgraded. a/kernel-modules-6.1.63-x86_64-1.txz: Upgraded. a/mkinitrd-1.4.11-x86_64-34.txz: Rebuilt. Fix tests for including jfs/xfs repair tools. Thanks to regdub. a/pkgtools-15.1-noarch-8.txz: Rebuilt. Make vim the default vi choice. ap/vim-9.0.2116-x86_64-1.txz: Upgraded. d/gettext-tools-0.22.4-x86_64-1.txz: Upgraded. d/git-2.43.0-x86_64-1.txz: Upgraded. d/kernel-headers-6.1.63-x86-1.txz: Upgraded. d/mercurial-6.6-x86_64-1.txz: Upgraded. d/meson-1.3.0-x86_64-1.txz: Upgraded. d/scons-4.6.0-x86_64-1.txz: Upgraded. k/kernel-source-6.1.63-noarch-1.txz: Upgraded. l/readline-8.2.007-x86_64-1.txz: Upgraded. n/c-ares-1.22.1-x86_64-1.txz: Upgraded. n/nfs-utils-2.6.4-x86_64-1.txz: Upgraded. x/libdrm-2.4.118-x86_64-1.txz: Upgraded. xap/mozilla-firefox-115.5.0esr-x86_64-1.txz: Upgraded. This update contains security fixes and improvements. Thanks to zuriel for the taskbar icon fix on Wayland. :-) For more information, see: https://www.mozilla.org/en-US/firefox/115.5.0/releasenotes/ https://www.mozilla.org/security/advisories/mfsa2023-50/ https://www.cve.org/CVERecord?id=CVE-2023-6204 https://www.cve.org/CVERecord?id=CVE-2023-6205 https://www.cve.org/CVERecord?id=CVE-2023-6206 https://www.cve.org/CVERecord?id=CVE-2023-6207 https://www.cve.org/CVERecord?id=CVE-2023-6208 https://www.cve.org/CVERecord?id=CVE-2023-6209 https://www.cve.org/CVERecord?id=CVE-2023-6212 (* Security fix *) xap/vim-gvim-9.0.2116-x86_64-1.txz: Upgraded. xap/xsnow-3.7.6-x86_64-1.txz: Upgraded. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. testing/packages/kernel-generic-6.6.2-x86_64-1.txz: Added. testing/packages/kernel-headers-6.6.2-x86-1.txz: Added. testing/packages/kernel-huge-6.6.2-x86_64-1.txz: Added. testing/packages/kernel-modules-6.6.2-x86_64-1.txz: Added. testing/packages/kernel-source-6.6.2-noarch-1.txz: Added. usb-and-pxe-installers/usbboot.img: Rebuilt.
Diffstat (limited to 'testing/source/linux-6.6.x/kernel-headers.SlackBuild')
-rwxr-xr-xtesting/source/linux-6.6.x/kernel-headers.SlackBuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/testing/source/linux-6.6.x/kernel-headers.SlackBuild b/testing/source/linux-6.6.x/kernel-headers.SlackBuild
new file mode 100755
index 000000000..2721350a1
--- /dev/null
+++ b/testing/source/linux-6.6.x/kernel-headers.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Copyright 2018 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# To use this script, point it to a Linux kernel source tree, and it will make
+# the kernel-headers package using the .config to get all needed package
+# version information:
+#
+# KERNEL_SOURCE=/usr/src/linux ./kernel-headers.SlackBuild
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PKGNAM=${PKGNAM:-kernel-headers}
+BUILD=${BUILD:-1}
+KERNEL_SOURCE=${KERNEL_SOURCE:-/usr/src/linux}
+if [ -z "${HEADERS_ARCH}" ]; then
+ case "$(uname -m)" in
+ i?86) HEADERS_ARCH=x86 ;;
+ x86_64) HEADERS_ARCH=x86 ;;
+ # Use uname -m for all other archs:
+ *) HEADERS_ARCH=$(uname -m) ;;
+ esac
+fi
+if [ ! -d "${KERNEL_SOURCE}" ]; then
+ echo "Error: kernel source directory ${KERNEL_SOURCE} does not exist."
+ exit 1
+elif [ ! -r ${KERNEL_SOURCE}/.config ]; then
+ echo "Error: a .config was not found in ${KERNEL_SOURCE}."
+ exit 1
+fi
+# Get the kernel version from the kernel Makefile:
+VERSION=$(grep "^VERSION = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev).$(grep "^PATCHLEVEL = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev).$(grep "^SUBLEVEL = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev)$(grep "^EXTRAVERSION = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev)
+# Set LOCALVERSION to the value found inside the .config:
+LOCALVERSION="$(cat ${KERNEL_SOURCE}/.config 2> /dev/null | grep CONFIG_LOCALVERSION= | cut -f 2 -d = | tr -d \")"
+
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PKGNAM
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "kernel-headers-$(echo ${VERSION} | tr - _)$(echo ${LOCALVERSION} | tr - _)-${HEADERS_ARCH}-$BUILD.txz"
+ exit 0
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+mkdir -p $PKG/usr
+
+# Generate the kernel headers and clean them up:
+( cd ${KERNEL_SOURCE}
+ echo "Generating headers from the Linux kernel source tree in ${KERNEL_SOURCE}:"
+ make headers_install ARCH=${HEADERS_ARCH} INSTALL_HDR_PATH=$PKG/usr
+ cd $PKG/usr/include
+ # You won't want these files. The ones in libdrm work better.
+ rm -rf drm
+ # This next part seems pretty much cosmetic, but since we've been doing this
+ # for a long time (and others also do), we'll stick with it:
+ mv asm asm-${HEADERS_ARCH}
+ ln -sf asm-${HEADERS_ARCH} asm
+ # Remove unneeded dotfiles:
+ find . -name ".??*" -exec rm -f {} \+
+)
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc/slack-desc.kernel-headers > $PKG/install/slack-desc
+
+# Make the package:
+cd $PKG
+/sbin/makepkg -l y -c n $TMP/kernel-headers-$(echo ${VERSION} | tr - _)$(echo ${LOCALVERSION} | tr - _)-${HEADERS_ARCH}-$BUILD.txz
+