summaryrefslogtreecommitdiffstats
path: root/testing/source/linux-6.1.x/kernel-modules.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2023-01-07 20:30:44 +0000
committer Eric Hameleers <alien@slackware.com>2023-01-07 22:37:31 +0100
commite0eaf6e451b08cc5af9d17258f2c6157cb424efe (patch)
tree7b19d7e800954fc6c0bdc2b61e49771fd137c7c3 /testing/source/linux-6.1.x/kernel-modules.SlackBuild
parent34e6259d47376c3e767368d52f9aa20eafa49951 (diff)
downloadcurrent-e0eaf6e451b08cc5af9d17258f2c6157cb424efe.tar.gz
current-e0eaf6e451b08cc5af9d17258f2c6157cb424efe.tar.xz
Sat Jan 7 20:30:44 UTC 202320230107203044
We're going to go ahead and jump to the 6.1.4 kernel, in spite of the fact that a kernel bisect identified the patch that was preventing 32-bit from booting here on a Thinkpad X1E: ------ From 2e479b3b82c49bfb9422274c0a9c155a41caecb7 Mon Sep 17 00:00:00 2001 From: Michael Kelley <mikelley@microsoft.com> Date: Wed, 16 Nov 2022 10:41:24 -0800 Subject: [PATCH] x86/ioremap: Fix page aligned size calculation in __ioremap_caller() commit 4dbd6a3e90e03130973688fd79e19425f720d999 upstream. Current code re-calculates the size after aligning the starting and ending physical addresses on a page boundary. But the re-calculation also embeds the masking of high order bits that exceed the size of the physical address space (via PHYSICAL_PAGE_MASK). If the masking removes any high order bits, the size calculation results in a huge value that is likely to immediately fail. Fix this by re-calculating the page-aligned size first. Then mask any high order bits using PHYSICAL_PAGE_MASK. Fixes: ffa71f33a820 ("x86, ioremap: Fix incorrect physical address handling in PAE mode") ------ The non-SMP non-PAE 32-bit kernel is fine even without the patch revert. The PAE kernel also works fine with this patch reverted without any need to revert ffa71f33a820 (the patch that this one is supposed to fix). The machine's excessive (for 32-bit) amount of physical RAM (64GB) might also be a factor here considering the PAE kernel works on all the other machines around here without reverting this patch. The patch is reverted only on 32-bit. Upstream report still pending. Enjoy! :-) a/kernel-generic-6.1.4-x86_64-1.txz: Upgraded. a/kernel-huge-6.1.4-x86_64-1.txz: Upgraded. a/kernel-modules-6.1.4-x86_64-1.txz: Upgraded. a/tree-2.1.0-x86_64-1.txz: Upgraded. d/kernel-headers-6.1.4-x86-1.txz: Upgraded. k/kernel-source-6.1.4-noarch-1.txz: Upgraded. l/gvfs-1.50.3-x86_64-1.txz: Upgraded. l/hunspell-1.7.2-x86_64-1.txz: Upgraded. l/libnice-0.1.21-x86_64-1.txz: Upgraded. n/tin-2.6.2-x86_64-1.txz: Upgraded. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
Diffstat (limited to 'testing/source/linux-6.1.x/kernel-modules.SlackBuild')
-rwxr-xr-xtesting/source/linux-6.1.x/kernel-modules.SlackBuild146
1 files changed, 0 insertions, 146 deletions
diff --git a/testing/source/linux-6.1.x/kernel-modules.SlackBuild b/testing/source/linux-6.1.x/kernel-modules.SlackBuild
deleted file mode 100755
index d7df6d3c4..000000000
--- a/testing/source/linux-6.1.x/kernel-modules.SlackBuild
+++ /dev/null
@@ -1,146 +0,0 @@
-#!/bin/sh
-
-# Copyright 2018, 2020, 2022 Patrick J. Volkerding, Sebeka, Minnesota, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# To use this script, point it to a Linux kernel source tree and a .config
-# file by setting the appropriate environment variables:
-#
-# KERNEL_SOURCE=/usr/src/linux KERNEL_CONFIG=./kernel-configs/config-generic-4.14.23 ./kernel-modules.SlackBuild
-#
-# By default, it will use the source and .config already in /usr/src/linux (if possible).
-
-# KERNEL_NAME is optional, and we don't use it. Define it to "-name" if
-# you'd like an extra string after "kernel" in the package name
-# (i.e. "kernel-name-modules").
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-KERNEL_NAME=${KERNEL_NAME:-}
-KERNEL_SOURCE=${KERNEL_SOURCE:-/usr/src/linux}
-KERNEL_CONFIG=${KERNEL_CONFIG:-/usr/src/linux/.config}
-BUILD=${BUILD:-1}
-
-# The CONFIG_DEBUG_INFO_BTF_MODULES option adds a huge amount of debugging
-# data to the modules which we don't actually need. We'll strip debugging
-# information from kernel modules by default. If you are building a debug
-# kernel and wish to retain this data, export the variable below set to "NO".
-STRIP_DEBUG=${STRIP_DEBUG:-YES}
-
-if [ ! -r "${KERNEL_CONFIG}" ]; then
- echo "Error: the KERNEL_CONFIG environment variable needs to be set to the"
- echo ".config file to be used to build these modules. Example:"
- echo "KERNEL_SOURCE=/usr/src/linux KERNEL_CONFIG=./kernel-configs/config-generic-4.14.23 ./kernel-modules.SlackBuild"
- exit 1
-fi
-if [ ! -d "${KERNEL_SOURCE}" ]; then
- echo "Error: kernel source directory ${KERNEL_SOURCE} does not exist."
- exit 1
-fi
-# Get the kernel version from the kernel Makefile:
-VERSION=$(grep "^VERSION = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev).$(grep "^PATCHLEVEL = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev).$(grep "^SUBLEVEL = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev)$(grep "^EXTRAVERSION = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev)
-# Set LOCALVERSION to the value found inside the .config:
-LOCALVERSION="$(cat ${KERNEL_SOURCE}/.config 2> /dev/null | grep CONFIG_LOCALVERSION= | cut -f 2 -d = | tr -d \")"
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- # We will need to copy the config and run make oldconfig and make
- # prepare in order to generate kernel/bounds.s, where we can find
- # the true $PACKAGE_ARCH.
- if [ ! "${KERNEL_CONFIG}" = "${KERNEL_SOURCE}/.config" ]; then
- cp -a ${KERNEL_CONFIG} ${KERNEL_SOURCE}/.config
- fi
- cd ${KERNEL_SOURCE}
- make oldconfig 1> /dev/null 2> /dev/null
- make prepare 1> /dev/null 2> /dev/null
- PACKAGE_ARCH=$(cat kernel/bounds.s | grep -w "\-march=.*" | tr " " "\n" | grep -w "\-march=.*" | cut -f 2 -d = | tr - _)
- echo "kernel${KERNEL_NAME}-modules${LOCALVERSION}-$(echo ${VERSION} | tr - _)$(echo ${LOCALVERSION} | tr - _)-${PACKAGE_ARCH}-$BUILD.txz"
- exit 0
-fi
-
-NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
-TMP=${TMP:-/tmp}
-PKG=$TMP/package-kernel${KERNEL_NAME}-modules
-
-rm -rf $PKG
-mkdir -p $TMP $PKG
-
-# Set the variable $KERNEL_CLEAN to anything to run "make clean" before the
-# build. Default is to start compiling in the tree as we found it.
-if [ ! -z "${KERNEL_CLEAN}" ]; then
- ( cd ${KERNEL_SOURCE}
- echo "Cleaning kernel source (make clean)..."
- make clean
- # Make sure header files aren't missing...
- make prepare
- # Don't package the kernel in the sources:
- find . -name "*Image" -exec rm "{}" \+
- # No need for these:
- rm -f .config.old .version
- find . -name "*.cmd" -exec rm -f "{}" \+
- rm .*.d
- )
-fi
-
-# Copy the .config into the kernel source directory (unless it's there already)
-if [ ! "${KERNEL_CONFIG}" = "${KERNEL_SOURCE}/.config" ]; then
- echo "Copying the .config file to the kernel source tree:"
- cp -a --verbose ${KERNEL_CONFIG} ${KERNEL_SOURCE}/.config
-fi
-
-( cd ${KERNEL_SOURCE}
- echo "Running make oldconfig..."
- make oldconfig
- echo "Running a preliminary make (needed to create modules.builtin.modinfo)..."
- make $NUMJOBS || exit 1
- echo "Building kernel modules..."
- make $NUMJOBS modules || exit 1
- echo "Installing kernel modules to $PKG..."
- make INSTALL_MOD_PATH=$PKG modules_install || exit 1
- if [ "$STRIP_DEBUG" = "YES" ]; then
- echo "Stripping debug info from kernel modules..."
- find $PKG -name "*.ko" -exec strip --strip-debug "{}" \;
- fi
- # Fix build and source symlinks if they are pointing into $TMP:
- ( cd $PKG/lib/modules/${VERSION}${LOCALVERSION}
- for symlink in build source ; do
- target=$(readlink $symlink)
- if echo $target | grep -q "^$TMP/package-kernel-source/" ; then
- rm -f $symlink
- ln -sf $(echo $target | sed "s|$TMP/package-kernel-source/|/|g") $symlink
- fi
- done
- )
- depmod -b $PKG -a ${VERSION}${LOCALVERSION}
-) || exit 1
-
-mkdir $PKG/install
-cat $CWD/slack-desc/slack-desc.kernel-modules-template | sed "s/%PACKAGE_NAME%/kernel${KERNEL_NAME}-modules${LOCALVERSION}/g" > $PKG/install/slack-desc
-
-# Fetch the kernel architecture from the source tree:
-cd ${KERNEL_SOURCE}
-PACKAGE_ARCH=$(cat kernel/bounds.s | grep -w "\-march=.*" | tr " " "\n" | grep -w "\-march=.*" | cut -f 2 -d = | tr - _)
-
-# Make the package:
-cd $PKG
-/sbin/makepkg -l y -c n $TMP/kernel${KERNEL_NAME}-modules${LOCALVERSION}-$(echo ${VERSION} | tr - _)$(echo ${LOCALVERSION} | tr - _)-${PACKAGE_ARCH}-$BUILD.txz
-