summaryrefslogtreecommitdiffstats
path: root/testing/source/linux-6.1.x/kernel-headers.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2023-01-07 20:30:44 +0000
committer Eric Hameleers <alien@slackware.com>2023-01-07 22:37:31 +0100
commite0eaf6e451b08cc5af9d17258f2c6157cb424efe (patch)
tree7b19d7e800954fc6c0bdc2b61e49771fd137c7c3 /testing/source/linux-6.1.x/kernel-headers.SlackBuild
parent34e6259d47376c3e767368d52f9aa20eafa49951 (diff)
downloadcurrent-e0eaf6e451b08cc5af9d17258f2c6157cb424efe.tar.gz
current-e0eaf6e451b08cc5af9d17258f2c6157cb424efe.tar.xz
Sat Jan 7 20:30:44 UTC 202320230107203044
We're going to go ahead and jump to the 6.1.4 kernel, in spite of the fact that a kernel bisect identified the patch that was preventing 32-bit from booting here on a Thinkpad X1E: ------ From 2e479b3b82c49bfb9422274c0a9c155a41caecb7 Mon Sep 17 00:00:00 2001 From: Michael Kelley <mikelley@microsoft.com> Date: Wed, 16 Nov 2022 10:41:24 -0800 Subject: [PATCH] x86/ioremap: Fix page aligned size calculation in __ioremap_caller() commit 4dbd6a3e90e03130973688fd79e19425f720d999 upstream. Current code re-calculates the size after aligning the starting and ending physical addresses on a page boundary. But the re-calculation also embeds the masking of high order bits that exceed the size of the physical address space (via PHYSICAL_PAGE_MASK). If the masking removes any high order bits, the size calculation results in a huge value that is likely to immediately fail. Fix this by re-calculating the page-aligned size first. Then mask any high order bits using PHYSICAL_PAGE_MASK. Fixes: ffa71f33a820 ("x86, ioremap: Fix incorrect physical address handling in PAE mode") ------ The non-SMP non-PAE 32-bit kernel is fine even without the patch revert. The PAE kernel also works fine with this patch reverted without any need to revert ffa71f33a820 (the patch that this one is supposed to fix). The machine's excessive (for 32-bit) amount of physical RAM (64GB) might also be a factor here considering the PAE kernel works on all the other machines around here without reverting this patch. The patch is reverted only on 32-bit. Upstream report still pending. Enjoy! :-) a/kernel-generic-6.1.4-x86_64-1.txz: Upgraded. a/kernel-huge-6.1.4-x86_64-1.txz: Upgraded. a/kernel-modules-6.1.4-x86_64-1.txz: Upgraded. a/tree-2.1.0-x86_64-1.txz: Upgraded. d/kernel-headers-6.1.4-x86-1.txz: Upgraded. k/kernel-source-6.1.4-noarch-1.txz: Upgraded. l/gvfs-1.50.3-x86_64-1.txz: Upgraded. l/hunspell-1.7.2-x86_64-1.txz: Upgraded. l/libnice-0.1.21-x86_64-1.txz: Upgraded. n/tin-2.6.2-x86_64-1.txz: Upgraded. isolinux/initrd.img: Rebuilt. kernels/*: Upgraded. usb-and-pxe-installers/usbboot.img: Rebuilt.
Diffstat (limited to 'testing/source/linux-6.1.x/kernel-headers.SlackBuild')
-rwxr-xr-xtesting/source/linux-6.1.x/kernel-headers.SlackBuild90
1 files changed, 0 insertions, 90 deletions
diff --git a/testing/source/linux-6.1.x/kernel-headers.SlackBuild b/testing/source/linux-6.1.x/kernel-headers.SlackBuild
deleted file mode 100755
index 2721350a1..000000000
--- a/testing/source/linux-6.1.x/kernel-headers.SlackBuild
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/bin/sh
-
-# Copyright 2018 Patrick J. Volkerding, Sebeka, Minnesota, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# To use this script, point it to a Linux kernel source tree, and it will make
-# the kernel-headers package using the .config to get all needed package
-# version information:
-#
-# KERNEL_SOURCE=/usr/src/linux ./kernel-headers.SlackBuild
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PKGNAM=${PKGNAM:-kernel-headers}
-BUILD=${BUILD:-1}
-KERNEL_SOURCE=${KERNEL_SOURCE:-/usr/src/linux}
-if [ -z "${HEADERS_ARCH}" ]; then
- case "$(uname -m)" in
- i?86) HEADERS_ARCH=x86 ;;
- x86_64) HEADERS_ARCH=x86 ;;
- # Use uname -m for all other archs:
- *) HEADERS_ARCH=$(uname -m) ;;
- esac
-fi
-if [ ! -d "${KERNEL_SOURCE}" ]; then
- echo "Error: kernel source directory ${KERNEL_SOURCE} does not exist."
- exit 1
-elif [ ! -r ${KERNEL_SOURCE}/.config ]; then
- echo "Error: a .config was not found in ${KERNEL_SOURCE}."
- exit 1
-fi
-# Get the kernel version from the kernel Makefile:
-VERSION=$(grep "^VERSION = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev).$(grep "^PATCHLEVEL = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev).$(grep "^SUBLEVEL = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev)$(grep "^EXTRAVERSION = " ${KERNEL_SOURCE}/Makefile | rev | cut -f 1 -d ' ' | rev)
-# Set LOCALVERSION to the value found inside the .config:
-LOCALVERSION="$(cat ${KERNEL_SOURCE}/.config 2> /dev/null | grep CONFIG_LOCALVERSION= | cut -f 2 -d = | tr -d \")"
-
-TMP=${TMP:-/tmp}
-PKG=$TMP/package-$PKGNAM
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "kernel-headers-$(echo ${VERSION} | tr - _)$(echo ${LOCALVERSION} | tr - _)-${HEADERS_ARCH}-$BUILD.txz"
- exit 0
-fi
-
-rm -rf $PKG
-mkdir -p $TMP $PKG
-mkdir -p $PKG/usr
-
-# Generate the kernel headers and clean them up:
-( cd ${KERNEL_SOURCE}
- echo "Generating headers from the Linux kernel source tree in ${KERNEL_SOURCE}:"
- make headers_install ARCH=${HEADERS_ARCH} INSTALL_HDR_PATH=$PKG/usr
- cd $PKG/usr/include
- # You won't want these files. The ones in libdrm work better.
- rm -rf drm
- # This next part seems pretty much cosmetic, but since we've been doing this
- # for a long time (and others also do), we'll stick with it:
- mv asm asm-${HEADERS_ARCH}
- ln -sf asm-${HEADERS_ARCH} asm
- # Remove unneeded dotfiles:
- find . -name ".??*" -exec rm -f {} \+
-)
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc/slack-desc.kernel-headers > $PKG/install/slack-desc
-
-# Make the package:
-cd $PKG
-/sbin/makepkg -l y -c n $TMP/kernel-headers-$(echo ${VERSION} | tr - _)$(echo ${LOCALVERSION} | tr - _)-${HEADERS_ARCH}-$BUILD.txz
-