summaryrefslogtreecommitdiffstats
path: root/source/xap/rxvt-unicode/rxvt-unicode.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2023-07-20 19:55:25 +0000
committer Eric Hameleers <alien@slackware.com>2023-07-20 22:31:39 +0200
commit94e7610642c1a4294f72d31c4a0f62bfc28a8aac (patch)
tree5a2ca7a6536f7ed9a3fde1f074bd40a798d2905a /source/xap/rxvt-unicode/rxvt-unicode.SlackBuild
parent6f8b2b4fabce9d8d0571802529cad2df31d9a0ca (diff)
downloadcurrent-94e7610642c1a4294f72d31c4a0f62bfc28a8aac.tar.gz
current-94e7610642c1a4294f72d31c4a0f62bfc28a8aac.tar.xz
Thu Jul 20 19:55:25 UTC 202320230720195525
d/re2c-3.1-x86_64-1.txz: Upgraded. l/gst-plugins-bad-free-1.22.5-x86_64-1.txz: Upgraded. l/gst-plugins-base-1.22.5-x86_64-1.txz: Upgraded. l/gst-plugins-good-1.22.5-x86_64-1.txz: Upgraded. l/gst-plugins-libav-1.22.5-x86_64-1.txz: Upgraded. l/gstreamer-1.22.5-x86_64-1.txz: Upgraded. l/libptytty-2.0-x86_64-1.txz: Added. This is required by rxvt-unicode-9.31. x/libpthread-stubs-0.5-x86_64-1.txz: Upgraded. xap/rxvt-unicode-9.31-x86_64-1.txz: Upgraded. Compiled against libptytty-2.0. testing/packages/mozilla-thunderbird-115.0.1-x86_64-1.txz: Upgraded. This release contains security fixes and improvements. For more information, see: https://www.mozilla.org/en-US/thunderbird/115.0.1/releasenotes/ (* Security fix *)
Diffstat (limited to 'source/xap/rxvt-unicode/rxvt-unicode.SlackBuild')
-rwxr-xr-xsource/xap/rxvt-unicode/rxvt-unicode.SlackBuild20
1 files changed, 2 insertions, 18 deletions
diff --git a/source/xap/rxvt-unicode/rxvt-unicode.SlackBuild b/source/xap/rxvt-unicode/rxvt-unicode.SlackBuild
index fd8d48d8f..2ab0bf31e 100755
--- a/source/xap/rxvt-unicode/rxvt-unicode.SlackBuild
+++ b/source/xap/rxvt-unicode/rxvt-unicode.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2018 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# Copyright 2018, 2023 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=rxvt-unicode
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-7}
+BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -85,24 +85,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-# Add support for utempter:
-zcat $CWD/rxvt-unicode.utempter.diff.gz | patch -p1 --verbose || exit 1
-
-# Security fix:
-zcat $CWD/CVE-2022-4170.diff.gz | patch -p1 --verbose || exit 1
-
# Fix special character rendering with perl-5.38.0:
zcat $CWD/rxvt-unicode.perl5.38.0.diff.gz | patch -p1 --verbose || exit 1
-# Regenerate configure from configure.ac after patching in utempter support:
-autoreconf -vif
-
-# Obsolete options (due to utempter patch):
-# --enable-utmp \
-# --enable-wtmp \
-# --enable-lastlog \
-#
-
run_configure() {
# Configure:
CFLAGS="$SLKCFLAGS" \
@@ -133,7 +118,6 @@ CFLAGS="$SLKCFLAGS" \
--enable-frills \
--enable-mousewheel \
--enable-slipwheeling \
- --enable-smart-resize \
$COLOR_OPTS \
--build=$ARCH-slackware-linux || exit 1
}