summaryrefslogtreecommitdiffstats
path: root/source/l/gc/gc.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2023-05-27 20:42:29 +0000
committer Eric Hameleers <alien@slackware.com>2023-05-27 23:35:44 +0200
commitb6e754b75028501e93887121e69caaf5d4d34b12 (patch)
tree1641ff3d9f3eefaba4ec8a7c013737982a389fce /source/l/gc/gc.SlackBuild
parentce8a8775465331c6fd72f04d16ae33594ae67984 (diff)
downloadcurrent-b6e754b75028501e93887121e69caaf5d4d34b12.tar.gz
current-b6e754b75028501e93887121e69caaf5d4d34b12.tar.xz
Sat May 27 20:42:29 UTC 202320230527204229
d/gdb-13.2-x86_64-1.txz: Upgraded. l/gc-8.2.4-x86_64-1.txz: Upgraded. xap/mozilla-thunderbird-102.11.2-x86_64-1.txz: Upgraded. This is a bugfix release. For more information, see: https://www.mozilla.org/en-US/thunderbird/102.11.2/releasenotes/
Diffstat (limited to '')
-rwxr-xr-xsource/l/gc/gc.SlackBuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/source/l/gc/gc.SlackBuild b/source/l/gc/gc.SlackBuild
index 1bafa0377..23ccaf41e 100755
--- a/source/l/gc/gc.SlackBuild
+++ b/source/l/gc/gc.SlackBuild
@@ -27,7 +27,7 @@ PKGNAM=gc
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
-LAO_VERSION="7.6.14" # libatomic_ops version
+LAO_VERSION="7.8.0" # libatomic_ops version
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -74,6 +74,7 @@ tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
cd $PKGNAM-$VERSION 2> /dev/null || cd $PKGNAM-$(echo $VERSION | cut -b 1-3) || exit 1
tar xvf $CWD/libatomic_ops-$LAO_VERSION.tar.?z || exit 1
mv libatomic_ops-$LAO_VERSION libatomic_ops
+
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -83,7 +84,7 @@ find . \
sed -i 's#pkgdata#doc#' doc/doc.am
sed -i 's#pkgdata#doc#' libatomic_ops/Makefile.am
-sed -i 's#pkgdata#doc#' libatomic_ops/doc/Makefile.am
+#sed -i 's#pkgdata#doc#' libatomic_ops/doc/Makefile.am
autoreconf -vif
automake --add-missing